두 Dto가 비슷한 필드를 가지는 게 너무 많아서 상속을 통해서 구조를 바꾸려고 했다.
그러던 중 코드 리뷰를 받으면서 물론 이렇게 상속으로 표현하면 중복된 코드를 많이 줄일 수 있지만
나중에 새로운 기능이 추가될 때, 이 부모를 다시 사용할까도 생각해야 한다고 피드백을 받았다.
변수명과 함수명 짓기할 때 단어 선택 (0) | 2022.04.18 |
---|---|
실패 (0) | 2022.04.14 |
캐시 적용 (0) | 2022.04.12 |
jackson bind 오류 해결법 (0) | 2022.04.04 |
하드코딩...? (0) | 2022.03.24 |